A Request for Comments (RFC), in the context of Internet governance, is a type of publication from the Internet Engineering Task Force (IETF) and the Internet Society (ISOC), usually describing methods, behaviors, research, or innovations applicable to the working of the Internet and Internet-connected systems.
Almost every April Fools' Day (1 April) since 1989, the Internet RFC Editor has published one or more humorous Request for Comments (RFC) documents, following in the path blazed by the June 1973 RFC 527 called ARPAWOCKY, a parody of Lewis Carroll's nonsense poem "Jabberwocky". The following list also includes humorous RFCs published on other dates.
List of April Fools' Day RFCs
A parody of the TCP/IP documentation style. For a long time it was specially marked in the RFC index with "note date of issue".
Updated by RFC 2549 in 1999; see below. Describes protocol for transmitting IP packets by homing pigeon. In 2001, RFC 1149 was actually implemented by members of the Bergen Linux User Group. See also RFC 6214, as noted below. Describes the adaptation of RFC 1149 for IPv6.
Attributed to William Shakespeare.
This RFC is not solely for entertainment; the described protocol has regularly been implemented at hacker events in Europe.
Updated by RFC 7168 in 2014.
Updates RFC 1149.
Obsoletes MCMXCIX.
Concerning the practicalities of the infinite monkey theorem.
Proposal for the 'evil bit', as an option in the IPv4 packet header. Later, this became a synonym for all attempts to seek simple technical solutions for difficult human social problems which require the willing participation of malicious actors.
Notable for containing PDP-10 assembly language code nearly 22 years after the manufacturer ceased production of the PDP-10, and for being technically possible as opposed to many of these other proposals.
Implemented on Facebook by the author, in the process of writing the RFC.
Updates for coffee machines which are also capable of brewing tea. Also defines the HTTP response code 418 I'm a Teapot, for teapots to use when unable to brew coffee.
An April 1st RFC was not published this year.
Takes a rather mathematical approach to use the 128-bit IPv6 address space in other ways than the traditional one, to ultimately arrive at Complex Addresses. You may use the imaginary part of a complex address (with polar coordinates as the real part) to reach Santa Claus, for example. It also proposes to use Flying Addresses for end hosts using IP over avian carriers.
A heartfelt cry to end packet discrimination at the IP level, where they frequently (even in this day and age) are terminated prematurely, based on color, length, age, etcetera, or even by IP version!
Proposes to use 128-bit Unicode to facilitate internationalization of IPv6, since the 1.114.112 code points of the current implementation of Unicode is deemed insufficient for the future. IPv6 addressses may be represented by a single U+128 glyph, to reduce stress on the eyes of network administrators. If implemented, it would obsolete , because "[i]t was found to be too complex to implement anyway".
A 'response/request' protocol similar to HTTP/1.1 but where clients send a response to the server (e.g. "Hello World. My payload includes a trailing CRLF.") to which the server answers with a request (e.g. GET /hello.txt), like in the Jeopardy! game. The Hypertext Double Jeopardy Protocol (HTJ2P) (described in Appendix A) inverses the semantics of HTJP again.
The authors contend that the DNS (secured with DNSSEC) is most suited to globally and reliably provide information to help maintain a high quality of experience for CPE (among others). With the definition of four new DNS RR types (password, credit card number, social security number, and an SSN pointer record) they hope to create end-to-end, holistic network management.
Other humorous RFCs
Makes humorous statements about the NULL encryption algorithm.
Non-RFC IETF humor
An announcement on the IETF list about the appointment of the Sesame Street character Bert as member of the IAB appears to have been the April Fools' Day 2006 stunt.