The Host Identity Protocol (HIP) is a host identification technology for use on Internet Protocol (IP) networks, such as the Internet. The Internet has two main name spaces, IP addresses and the Domain Name System. HIP separates the end-point identifier and locator roles of IP addresses. It introduces a Host Identity (HI) name space, based on a public key security infrastructure.

The Host Identity Protocol provides secure methods for IP multihoming and mobile computing.

Host Identity Protocol

In networks that implement the Host Identity Protocol, all occurrences of IP addresses in applications are eliminated and replaced with cryptographic host identifiers. The cryptographic keys are typically, but not necessarily, self-generated.

Host Identity Protocol

The effect of eliminating IP addresses in application and transport layers is a decoupling of the transport layer from the internetworking layer (Internet Layer) in TCP/IP.

Host Identity Protocol

HIP was specified in the IETF HIP working group. An Internet Research Task Force (IRTF) HIP research group looks at the broader impacts of HIP.

The working group is chartered to produce Requests for Comments on the "Experimental" track, but it is understood that their quality and security properties should match the standards track requirements. The main purpose for producing Experimental documents instead of standards track ones are the unknown effects that the mechanisms may have on applications and on the Internet in the large.

RFC references

- Host Identity Protocol (HIP) Architecture (early "informational" snapshot) - Host Identity Protocol base (Obsoleted by RFC 7401) - Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP) (Obsoleted by RFC 7402) - Host Identity Protocol (HIP) Registration Extension (obsoleted by RFC 8003) - Host Identity Protocol (HIP) Rendezvous Extension (obsoleted by RFC 8004) - Host Identity Protocol (HIP) Domain Name System (DNS) Extension (obsoleted by RFC 8005) - End-Host Mobility and Multihoming with the Host Identity Protocol - NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) Communication - Basic Requirements for IPv6 Customer Edge Routers - Host identity protocol version 2 (HIPv2) (updated by RFC 8002) - Using the Encapsulating Security Payload (ESP) transport format with the Host Identity Protocol (HIP) - Host Identity Protocol Certificates - Host Identity Protocol (HIP) Registration Extension - Host Identity Protocol (HIP) Rendezvous Extension - Host Identity Protocol (HIP) Domain Name System (DNS) Extension - Host Mobility with the Host Identity Protocol - Host Multihoming with the Host Identity Protocol - Native NAT Traversal Mode for the Host Identity Protocol

See also

Identifier/Locator Network Protocol (ILNP) IPsec Locator/Identifier Separation Protocol (LISP) Mobile IP (MIP) Proxy Mobile IPv6 (PMIPv6)

References

External links

IETF HIP working group

IRTF HIP research group

OpenHIP Wiki

How HIP works - from InfraHIP site - Moved to How HIP works

HIP simulation framework for OMNeT++

Tempered Networks HIP-based Airwall family

Internet protocols

Multihoming

Cryptographic protocols

Computer network security

IPsec